Sign in to follow this  
Followers 0
styla

Gproxy tutorial

14 posts in this topic

Download ingame Gproxy

After some time our gproxy is ready to use. This version will scan in warcraft 3 folder for .mix files and report to bot and will ban player if found it. 

Added new variable in config file for players with password protect (no needed to type !pw password after join in lobby).

Config. and Usage:
1. unarchive files
2. open gproxy.cfg and change it like your w3 path :

CODE: SELECT ALL
war3path = C:\Warcraft III\ 

atention at \ from the end of line

 

Your  user acount and password regsitred at INGAME realm

username =
password = 
then save modification.

3. run gproxy.exe
4. warcraft 3 will be open, go LAN, and wait 1-5 seconds to see the game name and join, have fun!
If you have a router, forward port 6325.
to know: 
you must use /re for reply, not /r

Advantages of gproxy:
can join when game is full (safelisted)
faster time to join in lobby (auto start warctaft 3,and you just press LAN games :D)
reconnect protection (if u lose conection u can reconnect back to game http://www.youtube.com/watch?v=rTwMtWNLmA0 )
checked for mh ( no more acusation)
auto spoofcheck
admins can use !scan name command to check suspects players for mh.

Notes: the scan feature is not 100% accurate.
Added some countryes in forced list: KR MK IN NZ .
List of forced players: openstats/?gproxy

Share this post


Link to post
Share on other sites

Is there any reason to not be able to use eurobattle.net gproxy? It has the reconnect protection as well and all other things described above. Should I post a topic there and ask them why their client can not join ingame.ro games?

Share this post


Link to post
Share on other sites

Eurobattle gproxy works. It's just that it connects to only eurobattle you can't connect to other realm. As for why you can't join ingame games maybe because it's on version 1.27

Share this post


Link to post
Share on other sites

Posted (edited)

my gproxy.cfg file  ( I use W3 1.27) 

 

### required config values
################################################# update the w3 path, care at \ from ending of path.

war3path = D:\Games\w3\Warcraft3\
#####eurobattle.net user and password.###############
## here you can create a account: http://app.eurobattle.net/register

username = Ant
password = I_HIDE_IT


## Optinal,Protect Account anti spoofers (req. for admins!).
## More details here: http://ingame.ro/index.php?/topic/9-protect-warcraft-accounts-req-for-admins/
## don't use special characters like @ " (or space) 
## don't use spaces after/before password.
protectpassword = password
#Note:
##### If you have connection problems check port 6325. 
##### Must be open in router settings (Port Forwarding)

##### Eurobattle.net account must be reactivated once per month.
##### DO not change, you don't need.

cdkeyroc = FFFFFFFFFFFFFFFFFFFFFFFFFF
cdkeytft = FFFFFFFFFFFFFFFFFFFFFFFFFF
server = server.eurobattle.net
channel = smoke
### optional config values

war3version = 27
port = 6325
exeversion = 
exeversionhash = 
passwordhashtype = pvpgn

### curses config values

### the console buffer size / window size
term_width = 135
term_height = 52

### enable split view in realm window
curses_splitview = 1

### 0: horizontal lists, 1: vertical lists
curses_listtype = 1


 

Edited by Ant

Share this post


Link to post
Share on other sites

Posted (edited)

Try with other server and W3 version(1.26a+proxy1.26), error the same! Account (eurobattle.net) was activated yesterday. Ports  6112 and 6325 were opened. Password was written correctly.

I tried to comment/stay empty/stay without changes line:

protectpassword = password 

 but result was the same.
1.thumb.png.28ddb4011e42372ebc8fff63ea33

Edited by Ant

Share this post


Link to post
Share on other sites

it says connecting to w3.europebattle.net, are you sure you configured it right ?

It should be  server.eurobattle.net.

First try to connect through game directly instead of using gproxy to test if connection is ok, then you can use gproxy (make sure to choose the right realm!)

Share this post


Link to post
Share on other sites

Change your password, make a simplier password, no accent, punctuation

Share this post


Link to post
Share on other sites

I tried all combinations, with server  w3.europebattle.net and  server.eurobattle.net . (see screens attentively)

Directly connection was successful in both variants. Password simple only 8 digits without spaces.

 

 

12.png

Share this post


Link to post
Share on other sites

when i try to connect to gproxy in eurobattle.net i kicked by bot too.

12.png

1.png

Share this post


Link to post
Share on other sites

Eurobattle gproxy is not Ingame gproxy

If it says wrong password, it means wrong password simple. Remove any extra space before and after, like this :

password = IHIDEIT

Not password = [space][space]IHIDEIT[space][space]

Btw I see it display [Ant ] not [Ant] which mean you put an extra space in login

Share this post


Link to post
Share on other sites

There are no spaces, i check it before.

Share this post


Link to post
Share on other sites

Better i choose another IMBA server. If u can't make normal proxy/anticheat client, your project doomed to failure. Good Luck.

Share this post


Link to post
Share on other sites

We can all connect except you. You have a typing problem.

Bye.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0